PcTuner.Ru - VirtualDub v1.9.6

Данный материал взят с стайта PcTuner.ru - Софт и драйверы - Захват и обработка видео - VirtualDub v1.9.6

VirtualDub v1.9.6

Разработчик: Avery Lee
Дата: 20.09.2009-11:40

Особенности: Windows Free

Незаменимая программа для захвата, и особенно для обработки видео. Имеет небольшой размер, простой интерфейс и во-многом уникальные возможности. Также стоит обратить внимание, что программа абсолютно бесплатная!

Интерфейс VirtualDub Интерфейс VirtualDub Интерфейс VirtualDub

Дополнительно доступна 64-х битная версия программы. Она имеет оптимизацию под процессоры AMD Athlon 64, AMD Athlon FX, AMD Opteron, и Intel Xeon EM64T. Для запуска этой версии у вас обязательно должна быть установлена 64-х битная версия Windows. В обычной версии, даже если вы имеете соответствующий процессор, программу запустить не удастся.

Дополнительно:
  • Подборка плагинов для VirtualDub.
  • Руководство по VirtualDub.
  • VirtualDub v1.9.6 (1,520 Mb) - Версия AMD 64-bit

Загрузка:

  • Скачать VirtualDub v1.9.6 (1,371 MB) - 116793 загрузок


PcTuner.Ru - VirtualDub Plug-In

VirtualDub Plug-In

Разработчик: Dmitry Kornev
Дата: 06.05.2008-12:12

Особенности:

Подборка плагинов для VirtualDub, VirtualDubMod, NanDub. Основные условия отбора фильтров для этого списка – это бесплатность, ну и, конечно же, полезность. Список регулярно пополняется.

Деинтерлейс и другие фильтры для работы с полями интерлейсного видео.

  • Asvzzz Deinterlace v2.0 (0,002 Mb). Плагин от Сергея Андыка, эфективно устраняет гребенку, не имеет опций. Аналогичный фильтр встроен в его же программу FlyDS.

  • Smart Deinterlace v2.6b2 (0,011 Mb) - Отличный фильтр для устранения эффекта гребенки, предоставляет возможность изменить параметры фильтрации.

  • Smart Bob v1.1 beta 2 (0,024 Mb) - Этот фильтр действует аналогично Smart Deinterlace, за исключением того, что он удваивает на выходе частоту кадров. Например, если входящее интерлейсое видео имело 25 кадров в секунду, то на выходе прогрессивное видео будет иметь 50 кадров в секунду. Естественно, что плавность воспроизведения от этого возрастает.

  • AlparySoft Deinterlace (0,056 Mb) - По словам разработчиков преимущества Alparysoft фильтра по сравнению с аналогами в следующем. Существующие деинтерлейс фильтры фильтруют весь кадр, то есть те места на кадре, где не было движения, тоже подвергаются обработке. Из-за чего, в этих областях происходит потеря информации и ухудшения качества видео. Фильтр Alparysoft может автоматически определять интерлейсные места кадра и проводить фильтрацию только в этих местах, при этом части кадра, на которых не было движения, остаются высокого качества.

  • Deinterlace-Smooth v1.1 (0,028 Mb) - Фильтр от Gunnar Thalin, генерирует высокое разрешение по вертикали, прогрессивного 50/60fps видео записанного как обычное 25/30fps чересстрочное видео. В стандарте PAL могут существовать 2 типа видео: 50fps видео с половинчатым вертикальным разрешением и 25fps видео с полным вертикальным разрешением. Оба эти типа обычно захватываются как 25fps полноэкранное видео, соответственно для обеспечения 50fps каждый фрейм обычного видео будет состоять из двух кадров записанных черезстрочно. Аналогично и для системы NTSC, только количество кадров там 60/30 соответственно. Этот фильтр предназначен для восстановления разрешения по вертикали для видео с высоким fps.

  • Deinterlace Area Based v1.4 (0,028 Mb) - Деинтерлейс фильтр от Gunnar Thalin, удаляет чередующиеся линии только в тех местах, где они видны. Анализируется каждый кадр в отдельности, и за счет деинтерлейс обработки только там, где она требуется, достигается высокое качество итогового видео. Не обработанные места имеют исходное качество, и исходную прорисовку. Там где требуется деинтерлейс обработка, происходит как обычно смешивание полей или интерполяция.

  • Deinterlace MAP (Motion and Area Pixel) v1.0 (0,018 Mb) - Деинтерлейс фильтр от Shaun Faulds, базируется на двух других разработках. Во-первых, он использует код фильтра Deinterlace Area Based, поэтому анализирует каждый кадр и обрабатывает только те участки изображения, где произошло движение и наблюдается гребенка. Во-вторых, фильтр использует для обработки таких участков код и алгоритм лучшего деинтерлейс фильтра Smart Deinterlace.

  • Deinterlace PAL movie v1.1 (0,020 Mb) - Фильтр от Gunnar Thalin, исправляет видео, которое должно быть прогрессивным (без гребенки), но, тем не менее, содержит интерлейсные линии.

  • Deinterlace PAL Interpolation v1.0b1 (0,032 Mb) - Фильтр от tHE fISH, исправляет видео, которое должно быть прогрессивным (без гребенки), но, тем не менее, содержит интерлейсные линии. В отличие от предыдущего фильтра, здесь на выходе осуществляется дополнительная проверка и если линии все же остались, осуществляется их устранение методом интерполяции.

  • Deinterlacer - Auto PAL movie v3.4b1 (0,122 Mb) - Фильтр от Simon Walters, автоматически восстанавливает порядок чередования полей для интерлейсного PAL видео. Этот фильтр для всех, кто когда-нибудь пытался восстанавливать оригинальный порядок полей и имел проблему с порядком их чередования. После обработки этим фильтром, видео можно будет рассматривать как прогрессивное. Это означает, что вы можете выключить интерлейс обработку в MPEG-2 кодеке, что должно отразиться на меньшем количестве артефактов вследствие более эффективного сжатия.

  • Dynamic Field Order Correction v1.0 (0,030 Mb) - Фильтр от Shaun Faulds, пытается максимально возможно восстановить интерлейсное видео в прогрессивный видеопоток. Алгоритм обработки построен таким образом, что фильтр должен восстановить даже перепутанные поля, динамически изменяющиеся по ходу отображения видео. Фильтр берет вначале верхнее поле текущего фрейма и сравнивает его, используя алгоритм обнаружения гребенки, с нижним полем этого же фрейма, потом с полем предшествующего и следующего фреймов видео. После чего анализирует результат и решает, какая комбинация лучше подходит. Обработка последующих фреймов происходит аналогичным образом.

  • Field Delay v1.0 (0,097 Mb) - Фильтр от Uwe Freese, позволяет задать, какие из полей интерлейсного видео будет идти первыми, четные или нечетные. Иногда при обработке интерлейсного видео из-за ошибки, или сбоя источников видео, можно столкнуться с ситуацией, что поля идут не в своей последовательности и как следствие, видео начинает, как бы подергиваться. Этот фильтр позволит это исправить. Посмотрите содержащуюся в архиве справку и особенно рисунки, будет понятнее.

  • Field Shift v1.0 (0,020 Mb) - Фильтр от Gunnar Thalin. Если Вы используете программу VirtualDub для видео сжатого MJPEG кодеком с разделением каждого фрейма на два подфрейма для удвоения частоты кадров (50fps или 60fps), вы, возможно, обратили внимание, что полученное видео перепрыгивает немного вверх и вниз. Что бы устранить этот дефект, каждый второй фрейм должен быть перемещен на одну линию вниз, данный фильтр позволяет это сделать, а, кроме того, позволяет удвоить разрешение видео по высоте.

Шумоподавление, сглаживание и резкость.

  • Vlafy NvDenoise Filter (0,162 Mb) - Фильтр пространственного шумоподавления. Включает два алгоритма — K-Nearest Neighbors Filter и Quick Non Local Means Filter. Позволяет быстро и эффективно понизить уровень шумов без существенной потери чёткости изображения. Поддерживается работа с интерлейсным видео. Для работы фильтра необходима видеокарта nVidia GeForce серии 8ххх (GF8400GS и выше). Полный список поддерживаемых видео- и специализированных карт можно посмотреть здесь.

  • Dynamic noise reduction (0,056 Mb) - В архиве 3 варанта фильтра от Steven Don, предназначены для устранения динамического шума. Фильтры имеют настройку в виде ползунка, таким образом, в зависимости от зашумленности вашего видео можно подстроить необходимый уровень фильтрации. Однако стоит учесть, что при излишне высоких значениях теряется динамика и самого видеоизображения. Просто включите на просмотр открытое в VirtualDub видео и подстраивайте до необходимого значения, результат можно видеть сразу. Применяя данный фильтр можно существенно повысить степень сжатия видео, не говоря уже о более очевидной вещи, как собственно фильтрация динамического шума.

  • Video DeNoise (0,018 Mb) - Фильтр для очистки видеоизображений от шума. Анализирует каждый кадр независимо от других, благодаря чему не вносит дополнительные искажения по сравнению с динамическими фильтрами (практически не происходит потеря четкости по сравнению с операцией blur), а в совокупности с высокой точностью определения шумов данный фильтр, вероятно, является лидером среди подобных фильтров для VirtualDub. Полезен при кодировании в MPEG4, т.к. даже после удаления незначительного шума размер кодируемого файла уменьшается. Избавляет от интерлесинга (эффекта "лесенки" или "расчески").

  • MSU Denoising Filter (0,032 Mb) - Фильтр применяется для обработки зашумлённого видеопотока, для повышения качества видео, либо для улучшения и облегчения последующей обработки, например, перед сжатием или выполнением деинтерлейсинга. Подробный обзор фильтра и описание настроек здесь.

  • 2d Comb Filter (0,032 Mb) - Устраняет мерцание линий. Честно говоря, не увидел заметного эффекта при использовании данного фильтра, может кто-то подскажет, в каких случаях он будет полезен ?

  • Chroma Noise Reduction v1.1 (0,035 Mb) - Фильтр от Gilles Mouchard, уменьшает шум в сигналах UV, не изменяя сигнала Y. Полезен для записей записанных с VHS носителей. Напомню, что существует несколько способов представления цвета, наиболее распространенная на компьютере - RGB. В то время как на телевидении, VHS рекордерах, MPEG, и тд. широко используется система YUV. В обозначении YUV: Y (luminancy) - интенсивность яркости, U (chrominancy1) и V (chrominancy2) - информация о степени яркости и насыщенности изображения. Так уж принято, что на магнитных VHS лентах, по ширине зарезервированное место под UV сигналы меньше, чем под Y сигнал, поскольку человеческий глаз значительно менее чувствителен к яркости, чем цвету. Как следствие, часть ленты, содержащая UV сигналы больше подвержена износу. Этот фильтр позволяет уменьшить шум UV сигналов, не оказывая влияния на Y сигнал, который обычно имеет и без того хорошее качество.

  • MSU Deblocking Filter (0,063 Mb) - Фильтр предназначен для восстановления качества видео, взятого с DVD (например, когда туда записано 4 часа видео с низким битрейтом), VideoCD или после видеокодеков H.261, H.263, DivX 3, DivX 4, XviD. Фильтр автоматически определяет уровень блочности кадра и конкретной части кадра, сохраняя максимум деталей. Так, в одном и том же фильме на сцене с медленным движением (практически без блочности) фильтр будет действовать минимально, а на сценах с сильным движением - будет работать в полную силу. Основным достоинством фильтра является то, что он поднимает интегральное качество в наиболее распространенной PSNR метрике по сравнению с оригинальным фильмом! Т.е. фильм после декомпрессии при сравнении с оригиналом показывает меньшее качество, чем фильм после декомпрессии и деблокинга. Подробный обзор фильтра и описание настроек здесь.

  • MSU Smart Sharpen Filter (0,032 Mb) - Фильтр позволяет увеличивать резкость изображения с минимальным увеличением шума. Подробный обзор фильтра и описание настроек здесь.

  • MSU Deflicker Filter (0,029 Mb) - Фильтр подавления мерцания видео (постоянное резкое изменение яркости кадров). Данный артефакт часто встречается в старых фильмах с хроникой. Фильтр будет очень полезен людям, занимающимся восстановлением видео. Подробный обзор фильтра и описание настроек здесь.

  • Deflicker Filter v.1.1 from Donald Graft (0,006 Mb) - Фильтр выравнивает резкие фреймовые изменения яркости (мерцание видео).

  • 2D Cleaner Filter (0,024 Mb) - Фильтр заменяет каждый пиксель видеоизображения среднерассчитанным значением соседних пикселей. Задается радиус учета соседних пикселей (0-10) и интенсивность (0-255). Можно включить опцию учитывающую, что обрабатываемое видео интрлейсное. Так же можно повысить резкость резких переходов на изображении "show sharp edges".

  • Area Smoother v0.1 from Daniel Vollmer (0,041 Mb) - Фильтр анализирует каждый кадр в отдельности и заменяет более-менее одинаково окрашенные области их усредненным значением цвета. В архиве сразу исходник.

  • Deshaker v1.6 (0,033 Mb) - Фильтр от Gunnar Thalin, представляет собой видеостабилизатор для VirtualDub. Позволяет устранить резкие рывки сделанные камерой при съемке. Может стабилизировать движения горизонтальном и вертикальном направлениях, а так же вращение и приближение. Для достижения наилучшего результата позволяет производить обработку в 2 прохода. Может использовать предшествующие и следующие кадры для заполнения утерянных фрагментов вызванных рывком камеры. Возможность самостоятельного покадрового управления. Кроме того масса установочных параметров для опытных пользователей.

  • Exorcist v1.0 (0,021 Mb) - Фильтр от Chris Wojdon, разработан для того что бы удалить эффект отраженного ТВ сигнала, на экране это проявляется в виде теней основных объектов. Позволяет сгладить тени и отражения объектов. Настройки фильтра позволяют подстроиться под конкретно вашу ситуацию, настроить сдвиг тени.

  • Coring v1.0 (0,020 Mb) - Фильтр от Paul Currie. Реализованы основные функции coring-а. Это процесс, где интенсивность пикселей сравнивается с пороговым значением (0-64) и они окрашиваются в абсолютно черное если значение ниже порогового. Что приводит к сокращению шумов в черных областях изображения, и реализовано во многих цифровых видеокамерах и чипах сбора данных (например линейка BT848).

    Параметры:
    - Threshold: Любому пикселю с интенсивностью ниже этого значения присваивается значение coring-а (обычно черный).
    - Core to threshold: Иногда coring приводит к резкому перепаду от темно-серого к черному, который может быть очень заметен. Этот эффект должен исчезнуть, если пиксели окрашивать не чисто в абсолютно черное, но и темно-серое.

    Опции предпросмотра:
    Облегчают выбор порогового значения, хорошо выделяя затрагиваемые пиксели.
    - Core to green: Временная установка значения coring-а в зеленый.
    - Brightness slider: Слайдер коррекции яркости для препросмотра.

Эффекты, цветокоррекция.

  • MSU OldCinema Filter v1.2 (0,043 Mb) - Фильтр предназначен для получения эффекта "старого кино". Для этого имеется возможность настройки цветовой гаммы старения пленки, а также набор артефактов для достижения большей реалистичности и придания ему вида "хроники". Подробный обзор фильтра и описание настроек здесь.

  • MSU Noise Generation Filter (0,028 Mb) - Фильтр позволяет добавлять в видеопоток искусственно сгенерированный шум: белый шум, розовый шум, цветные пятна. Подробный обзор фильтра и описание настроек здесь.

  • Bit Drop Filter v0.9beta from Simon Walters (0,028 Mb) - Очень простой фильтр. Позволяет уменьшить воспринимаемую битовую глубину видеоклипа. Вы можете произвольно любой бит (1-8) выставить на 1 или 0. По словам автора, получаемый при этом эффект напоминает видеоэффекты 1970-х годов.

  • Border Control Filter v2.35 from Simon Walters (0,021 Mb) - Позволяет добавить в видео бордюры. Раздельная настройка с любой стороны (слева, справа, сверху, снизу). Размер видеоизображения не меняется, бордюры накладываются внутрь на изображение с любой из сторон. Есть 4 варианта: просто закраска необходимым цветом, плавное затенение к краю, размытие (размазывание) и растяжка.

  • Border Smear Filter v1.0beta from Simon Walters (0,022 Mb) - Фильтр позволят добавить черные бордюры сверху и снизу видеоизображение. Размер изображения при этом не меняется, добавление происходит вовнутрь. Кроме простых черных, бордюры могут размазывать изображение, и плавно затеняться к краям.

  • ACDSee Filter Auto Levels (0,022 Mb) - Полностью автоматизирует процесс подстройки уровней яркости/контраста/цветности изображения. Фильтр постоянно анализирует видеоизображение и подстраивает уровни динамически. Фильтр не имеет настроек. Базируется на функции "Auto Levels" программы ACD Photo Enhancer, входящей в комплект ACDsee, отсюда и название фильтра.

  • Brightness/Contrast (UI Enhanced) v1.0 (0,017 Mb) - Фильтр от Donald Graft, позволяет плавно подстроить якость ± 100% и контрастность 0-200%.

  • Colours Brightness Contrast Gamma (0,033 Mb) - Фильтр от Alessandro Malanca, предназначен для плавной регулировки яркости, контрастности и гаммы. При изменении параметров отображает сразу RGB или общую гистограмму.

  • Color Equalizer v1.1 (0,025 Mb) - Фильтр от Tamбs B. Bakу, предназначен для раздельной регулировки цветов RGB. Старые видеокамеры иногда имеют неправильный цветной баланс, который проявляется в виде несколько окрашенных видеозаписей. Картинка иногда немного голубоватая, иногда имеет розовый оттенок и тд. Этот эффект легко можно исправить данным фильтром.

  • Colorize v1.1beta1 (0,028 Mb) - Фильтр от Donald Graft, Позволяет окрасить видео в выбранный цветовой оттенок, другие цвета убираются полностью. Получается как бы монохромное видео, основанное на выбранном цвете. Можно использовать, например, что бы придать вид старой кинопленки с коричневым оттенком.

Изменение размера видеоизображения.

  • 2:1 Vertical Reduction (0,026 Mb) - Просто уменьшает размер видеоизображения по вертикали в 2 раза.

Добавление/удаление логотипов, надписей, бегущих строк и тд.

  • MSU Subtitle&Logo Remover (0,041 Mb) - Фильтр предназначен для удаления субтитров и логотипов с видеоизображения. Реализованно полностью АВТОМАТИЧЕСКОЕ определение области логотипа, даже если логотип смещается в разных сценах. В фильтре используется компенсация движения для правильного заполнения области лого (эффект "наползания" объектов на логотип/субтитры для восстановления изображения). Подробный обзор фильтра и описание настроек здесь.

  • DeLogo v1.3.2 (0,318 Mb) - Фильтр от Karel Suhajda, предназначен для удаления логотипов с видеоизображения. Для удаления логотипа этим фильтром необходимо сохранить один из кадров видео с логотипом, открыть его в любом графическом редакторе, закрасить область с логотипом красным цветом, сохранить изображение и использовать его потом в качестве маски для удаления логотипа. В архиве с программой содержится мануал с рисунками, где все доступно и понятно показано.

  • Add Frame Numbers (0,093 Mb) - Достаточно продвинутый фильтр с множеством настроек для добавления в видео счетчика кадров, времени видео, и текущего времени. Настраиваемые начальные значения для отсчета, а так же интервалы времени. Позволяет выводить несколько счетчиков. Полностью настраиваемое расположение, шрифты, цвет и тд.

  • Alidator Filter (0,015 Mb) - Простейший фильтр, просто добавляет внизу видеоизображения текущую дату и время в формате "dd.mm.yyyy hh:mm:ss". Настроек не имеет. Ресурсов практически не требует, поэтому будет особенно полезен при захвате видео.

Фильтры для испытательных целей.

  • Dct-q-idct v1.1 (0,040 Mb) - Фильтр от Andreas Dittrich, написанный для испытательных целей. Накладывает прямо поверх видео статическую информацию о текущем видео. Информация динамически изменяется. Фильтр выводит следующую информацию: color subsampling, blockwise forward DCT, matrix based quantization, source coding, inverse-DCT (IDCT), color upsampling. Вы можете использовать любые матрицы квантования и немедленно видеть информацию о вашем видео. Тем самым вы можете проверить, например, эффективность применения и настроек других фильтров, включенных вами в VirtualDub и повысить по возможности коэффициент сжатия. Статическая информация может быть сохранена в фале.

Впомогательные фильтры.

  • Filter Blender v1.1 (0,020 Mb) - Вспомогательный фильтр для VirtualDub от Steven Don. Как известно VirtualDub имеет одно окно для назначения плагинов в одном порядке, соответственно вы можете создать лишь одну последовательность фильтров для обработки видео. Данный фильтр позволяет разделить эту последовательность на две ветки, которые будут обрабатываться одновременно, а потом снова собрать их в одну, таким образом, сложив результаты обработки. Фильтр имеет 3 опции: Begin Path 1, Begin Path 2 и Blend. Последняя опция в качестве дополнения позволяет задать % соотношение при смешивании двух веток.

  • Conditional v0.5b (0,461 Mb) - Фильтр от Dmitri Schamschurko, позволяет применить другой фильтр в зависимости от заданного условия.


PcTuner.Ru - VirtualDub - описания фильтров

VirtualDub - описания фильтров

Автор: Dmitry Kornev
Дата: 24.01.2002-07:20

Описание работы стандартных (встроенных) фильтров VirtualDub. Сразу скажу, что дополнительные фильтры можно найти здесь.

  • 2:1 reduction (high quality) - Уменьшает размер изображение по горизонтали и по вертикали ровно в 2 раза.

  • 3x3 average - Обрабатывает изображение, путем заменены каждого пикселя картинки на некоторый "средний пиксель", который получен после анализа соседних пикселей. :)

  • Blur и Blur more - В разной степени размывают изображение.

  • Box blur - Настраиваемый фильтр размытия изображение. В настройках есть кнопка "Show preview", нажав которую можно сразу видеть результат работы фильтра.

  • Brightness/Contrast - Позволяет изменить яркость и контрастность изображения.

  • Deinterlace - Встроенный фильтр для устранения "гребенки". Честно говоря результат его работы мне не понравился, лучше пользоваться внешним фильтром "Smart deinterlace".

  • Emboss - В Adobe Photoshop этот эффект называется "рельеф". Трудно на словах объяснить, что он делает, проще показать. :)

  • Flip horizontally - Перевернуть изображение по горизонтали.

  • Flip vertically - Перевернуть изображение по вертикали.

  • Grayscale - Делает изображение черно-белым.

  • Invert - Инвертирует цвета.

  • Levels - Фильтр позволяет корректировать уровень освещенности изображения. Предлагается, передвижением ползунков, выставить значение для самых темных/светлых пикселей, а так же некое среднее значение. Нажмите кнопку "Show Preview" что бы сразу следить за результатом работы фильтра. Так же, периодически, нажимайте кнопку "Sample frame", чтобы видеть гистограмму, по ней проще сориентироваться и проще выставить ползунки.

  • Motion blur - Размывает движения. Переместившиеся объекты исчезают несразу.

  • Null transform - Дословно : нулевая трансформация, т.е. сам по себе этот фильтр ничего не делает. Обычно он выбирается для подрезания неровных краев.

  • Resize - Позволяет изменить размер картинки. Задайте новые размеры ширины и высоты. В списке "Filter mode" я обычно выбираю "Precise bicubic (A=-1.0)", можете поэкспериментировать и выбрать что-то на свой вкус. Нажмите кнопку "Show Preview" что бы следить за происходящим.

  • Rotate - Поворачивает картинку на 90, 180 или 270 градусов.

  • Rotate2 - Этот фильтр представляет более широкие возможности поворота картинки, здесь угол поворота, вы вписываете сами.

  • Sharpen - Увеличивает контраст между сливающимися элементами в изображении, если попроще : увеличивает резкость изображения. :)

  • Smoother - Размывает картинку. Фильтр позволяет задать степень размытия.

  • Temporal smoother - Размывает картинку по времени. :) Фильтр чем-то похож на "Motion blur", но эффект несколько другой.

  • Threshold - Преобразует изображение в черно-белое (оттенки серого отсутствуют полностью).


PcTuner.Ru - VirtualDub - первые шаги

VirtualDub - первые шаги

Автор: Dmitry Kornev
Дата: 24.01.2002-18:54

VirtualDub - совсем не большая программа, всего 800 кб, представляет собой незаменимый инструмент при захвате и особенно при обработке видео.

Данное описание поможет вам разобраться в особенностях работы с данной программой. Оно не претендует на полноту, но тем не менее описывает основные, наиболее часто используемые, приемы работы.

  • Захват видео в VirtualDub
  • Обработка видео - вырезание ненужных фрагментов.
  • Обработка видео - варианты сохранения AVI.
  • Обработка видео - обработка изображения фильтрами.
  • Полезные советы по работе с VirtualDub.

Захват видео в VirtualDub

VirtualDub запущен, переходим в режим захвата видео.

По умолчанию файл в который будет производиться захват расположен на диске C: и называется Capture.avi, при необходимости это можно изменить.

Выбираем источник видео сигнала.

Я выбираю "Видеотюнер", тут же можно настроить яркость, контраст, насыщенность, ... , для этого необходимо выбрать закладку "параметры устройства". Если у вас эти параметры не доступны для регулировок - в этом виноват WDM драйвер, попробуйте поставить другой (я предпочитаю драйвер от Eduardo Jose Tagle).

Выбираем формат, в который будем производить захват.

При захвате под Windows2000/XP, используя WDM драйвер - максимальное разрешение, с которым можно захватить видео программой написанной под VideoForWindows (а VirtualDub именно такой и является), равно 352x288. Правда есть небольшое исключение, о котором я узнал совсем недавно: если использовать WDM драйвер от Eduardo Jose Tagle, то даже VideoForWindows программами можно захватить видео с высоким разрешением. Как такое возможно - не знаю, но факт остается фактом. :)

И так выбираем разрешением и глубину цвета. Глубину цвета, как уже говорилось, лучше выбирать YUY2.

Выбираем формат звука и количество кадров в секунду.

Чаще всего следует выбирать следующим образом, см. ниже.

По умолчанию, звук записывается без сжатия. На всякий случай можно зайти и убедиться, что все так и есть.

Должно быть выбрано "PCM", убедитесь, что все в порядке. Выбирать какой-то кодек для звука настоятельно не рекомендую, поскольку в этом случае звук обязательно разойдется с видео потоком.

Выбираем кодек для видео потока. Рекомендации по выбору и настройке кодека, можно найти в других статьях, здесь я на этом останавливаться не буду.

Необходимо выставить очень важную настройку, привязку видео потока к звуку. Возможно, опция уже выбрана, на всякий случай убедимся. Для этого заходим в настройки.

И смотрим, если нет, ставим пометку, против "Lock video stream to audio".

При желании можно подрезать неровные края. Для этого необходимо поставить галочку против "Enable" и зайти в "Set bounds ...", что бы выставить размеры обрезаемых полей.

Выставляя поля можно сразу видеть результат - это очень удобно.

Если позволяет производительность компьютера и есть желание можно, при захвате, наложить фильтры.

Теперь все готово и можно переходить непосредственно к захвату видео :

Кнопка F6 - начать захват.

Esc - прервать захват.

В ходе захвата можно видеть всю необходимую статистику.

Обработка видео в VirtualDub - вырезание ненужных фрагментов.

Допустим вы захватили с эфира какой-нибудь фильм, и пока этот фильм шел, раз десять вставляли различную рекламу, теперь требуется вырезать эту рекламу. Делается это очень просто.

Открываем файл в VirtualDub.

Находим кадр с которого начинается реклама. Искать саму рекламу быстрее и удобнее всего, претаскиванием бегунка, мышиным курсором.

Реклама найдена, теперь необходимо остановиться на кадре, с которого она начинается. Для этого удобно пользоваться клавишами со стрелками на клавиатуре [<] и [>] - переход на предыдущий и следующий кадр. Попробуйте также перемещаться стрелками с клавиатуры в сочитании с клавишами [Alt] или [Shift]. Тоже самое можно делать, нажимая кнопки на экране.

Теперь, кадр с которого начинается реклама найден, нажимаем на клавиатуре кнопку [Home], таким образом мы пометили начало удаляемого фрагмента. Тем же образом ищем конец рекламы, находим последний кадр рекламы - нажимаем [End]. Фрагмент выделен, что бы его удалить нажимаем [Delete]. Все, фрагмент удален !

Тоже самое можно делать нажимая кнопки на экране.

Что бы изменения вступили в силу необходимо сохранить AVI файл. Различные способы сохранения мы рассмотрим дальше.

Обработка видео в VirtualDub - варианты сохранения AVI.

При сохранении AVI файла необходимо определиться, что вы хотите получить в итоге, и в соответствии с этим сделать некоторые настройки. Возможно сохранение следующим образом :

  • Переработка, сжатие, аудио и видео потоков.
  • Переработка, сжатие, только видео потока - звук остается неизменным.
  • Переработка, сжатие, только аудио потока - видео остается неизменным.

Выставляем настройки для видео потока.

Если требуется сжать заново видео поток, возможно более компактным кодеком. Или обработать поток фильтрами, а затем так же его сжать - необходимо выбирать "Full processing mode".

Для звука все аналогично.

Выбрав "Full processing mode", убедитесь что, верно, выставлен и настроен аудио кодек.

Когда все настроено - сохраняем AVI.

Еще несколько моментов.

Можно сохранить видео совсем без звука. Для этого, соответственно, необходимо выбрать :

Можно и на оборот, сохранить только звук (в WAV файл). Это может понадобиться, например, для обработки звука в более продвинутом аудио редакторе. Мне приходилось вытаскивать, таким образом, звук, что бы обработает его фильтрами в CoolEdit.

Для этого, не требуется делать каких то специфических настроек. Просто открываем AVI файл в VirtualDub и сразу :

Что бы присоединить звук обратно к видео, делаем так: AVI файл должен быть уже открыт в VirtualDub, выбираем файл со звуком :

Теперь, если неободимо, просто сохранить все как есть, без всякой обработки - выбираем для видео и аудио потоков "Direct stream copy" и сохраняем AVI.

О том, когда не требуется полная переработка видео или звука.

Видео поток можно не пережимать, а просто выбрать "Direct stream copy" в случае, если вы лишь вырезали ненужные фрагменты. Фильтры при этом не накладывались.

Учтите только, что при этом вырез осуществляется по ключевым кадрам. И если у вас видео пожато с большими промежутками между ключевыми кадрами то, возможно, вы получите не совсем то, что хотели. Т.к. выбранные вами кадры для начала и конца выреза могут не совпадать с ключевыми. Это относиться в частности к видео потоку, сжатому в MPEG4.

Обработка видео в VirtualDub - обработка изображения фильтрами.

Обработка видео фильтрами может производиться непосредственно при захвате, но большинство фильтров, очень требовательны к ресурсам и поэтому мало пригодны для обработки в реальном времени. Поэтому чаще всего фильтрами приходится обрабатывать уже захваченное видео. Именно этот случай мы и рассмотрим подробно.

VirtualDub запущен и AVI файл, требующий обработки открыт. Переходим к выбору фильтров.

В открывшемся окне список сначала пустой, для добавления в него фильтра, нажимаем кнопку "Add ...".

Изначально программа VirtualDub уже содержит в себе некоторое количество фильтров, они встроены и в списке значатся как "Internal". Но встроенных фильтров часто бывает недостаточно. Так, например для того, что бы убрать "гребенку" лучше пользоваться внешним фильтром. Внешние фильтры скачиваются из интернета дополнительно.

Непосредственно сам фильтр (внешний) представляет собой файл с расширением .vdf , что бы подключить такой фильтр к VirtualDub необходимо просто поместить его в каталог "VirtualDubPlugins".

И так, выбрав один из фильтров, нажимаем "ОК".

Таким образом, мы выбираем необходимое количество фильтров, обязательно производим их настройку. Настроить фильтр можно, нажав кнопку "Configure ...".

Обязательно учтите, что в каком порядке расположены фильтры в этом списке, в том порядке они и будут накладываться на изображение. При необходимости можно двигать фильтры вверх или вниз - кнопки соответственно "Move Up" и Move Down".

Выбрав и настроив необходимые фильтры - нажимаем "ОК" и возвращаемся к нашему AVI файлу. Теперь мы можем видеть полученный результат.

Размеры кадров часто бывают очень большими, что даже не помещаются на экране монитора, как в выше приведенном примере. В этом случае, можно поменять местами исходный и полученный кадры. Т.е. при смене, слева мы будем полностью видеть кадр - результат, а исходный кадр, справа - уже что поместиться.

Теперь, что бы все эти фильтры окончательно наложить на исходный AVI файл его необходимо сохранить. Но предварительно обязательно убедиться, что для видео потока выбран "Full processing mode".

Собственно сохранение.

Полезные советы по работе с VirtualDub.

Совет 01 - Сохраняйте настройки обработки видео.

VirtualDub позволяет полностью сохранить настройки обработки видео (Меню "File" - "Save/Load Processing Settings..."). При этом сохраняется все : настройки и последовательность наложенных фильтров, вырезанные фрагменты, настройки кодеков, и т.д. Очень полезно, если часто приходиться обрабатывать однотипные видео файлы, или просто, часто приходится накладывать одну и ту же последовательность фильтров...

Совет 02 - Горячие клавиши перемещения по видео.

Очень удобно при движении по видео пользоваться следующими горячими клавишами :
[Shift] + стрелки [<] и [>] - предыдущий и следующий ключевой кадр (для перемещения по видео сжатому в MPEG4).
[Alt] + стрелки [<] и [>] - 50 кадров назад и вперед, соответственно (для перемещения по видео сжатому в MJPEG, Nuffyuv, ... т.к. здесь каждый кадр является ключевым).

Совет 03 - Комфортное MPEG4 кодирование в два прохода.

Когда все настройки VirtualDub и кодеков сжатия выставлены, и настало время производить первый проход сжатия в MPEG4, удобнее поступить следующим образом:

  • (уточняю) в настройках DivX кодека выбран первый проход.
  • Сохраняем, меню "File" - "Save as AVI ...", задаем имя и расположение AVI файла, а так же ставим галочку напротив "Don't run this job now...". Теперь жмем кнопку "Сохранить".
  • Заходим в настройки DivX кодека, выбираем второй проход. Напомню, что больше ничего менять нельзя!
  • Снова, меню "File" - "Save as AVI ...", задаем имя и расположение AVI файла (имя другое), а так же ставим галочку напротив "Don't run this job now...". Жмем кнопку "Сохранить".
  • Теперь, меню "File" - "Job control...". В открывшимся окне мы видим два назначенных нами задания (первый и второй проходы), жмем "Start".

По завершению первого прохода сжатия, VirtualDub сразу начнет выполнять второй проход. Согласитесь, это очень удобно...


PcTuner.Ru - Описания работы с софтом

Описания работы с софтом

Показано 3 публикаций
Заголовок Дата

VirtualDub - первые шаги

Описание работы в VirtualDub. Оцените огромные возможности этой небольшой программки, сделав первый шаг, вы уже не сможете отказаться от ее использования.
 24.01.2002

VirtualDub - описания фильтров

Описание работы стандартных фильтров VirtualDub
 24.01.2002

VirtualDub - соединяем несколько AVI файлов

Наверно многие сталкивались со сложностями соединения в программе VirtualDub несколько видеофайлов в один, данная статья подробно описывает возможные способы работы и решения возможных проблем.
 24.01.2002


PcTuner.Ru - VirtualDub - соединяем несколько AVI файлов

VirtualDub - соединяем несколько AVI файлов

Автор: Дмитрий Корнев
Дата: 24.01.2002-07:19

Соединять в один несколько AVI файлов, не такое простое дело, как может показаться по началу. Дело в том, что чаще всего отдельные фрагменты, имеют разный FPS, и именно по этой причине VirtualDub отказывается их соединять.

Разный FPS, другими словами разное количество кадров в секунду, могло получиться из-за того, что при захвате видео вы делали привязку видео потока к звуку, во избежание рассинхронизации видео и звука. Что же теперь делать, спросите вы...

Самый простой и верный способ избежать таких проблем - это захватывать видео не кусками, а все сразу. Тем более, что вы уже знаете, как создавать большие по продолжительности и по объему AVI файлы, и знаете, что особых проблем при этом нет.

Второй способ избежать проблем при склеивании файлов - это не делать привязки видео потока к звуку при захвате. Естественно, при этом вы рискуете получить рассинхронизацию, поэтому данное решение малопригодно.

Теперь я вас предупредил, что лучше так не делать и рассказал о том, как можно этого избежать. :) Поэтому переходим, непосредственно, к способу соединения...

1. Идеальный вариант - AVI файлы имеют одинаковый FPS.

Открываем в VirtualDub первый фрагмент, с которого в дальнейшем начнется будущий ролик.

Присоединяем, к уже открытому фрагменту, следующий, для этого выбираем команду:

Выбираем файл. Открытый, таким образом, файл будет присоединен в конец предыдущего.

Последующие фрагменты присоединяются так же. Как вы уже поняли, фрагменты необходимо присоединять именно в той последовательности, в которой они потом будут идти в конечном ролике.

Все фрагменты открыты, теперь, при желании вы можете производить любые манипуляции, перед тем как перейти к сохранению. Можете накладывать фильтры, вырезать не нужные куски и т.д.

Сохранить тоже можно по разному, можно с пережатием и без пережатия видео и аудио потоков.

В общем, не буду повторяться - вы все это знаете из предыдущих описаний...

2. Не идеальный вариант - AVI файлы имеют различный FPS.

Мы имеем некоторое количество видео фрагментов, которые в свою очередь имеют различный FPS. Сразу склеить их, при помощи VirtualDub, нам не удастся. Поэтому для начала все имеющиеся фрагменты необходимо привести к одному FPS, и это совсем не простая задача!

Меняя частоту кадров AVI, мы ускоряем или замедляем поток кадров, следовательно, меняем продолжительность AVI. Но при этом звуковая дорожка остается неизменной, VirtualDub не сопоставляет ее видео потоку! Поэтому, неизбежно получается рассинхронизация видео и аудио потоков.

Выясним FPS фрагментов, которые нужно соединить. Для этого, поочередно, каждый файл открываем в VirtualDub, в меню "Video" выбираем :

В открывшемся окне видим FPS текущего файла:

Запоминем или лучше записываем значение FPS. Открываем следующий AVI файли таким же образом выясняем его FPS, и т.д.

  • Если вы видите, что FPS всех файлов меняется незначительно - рассчитайте или приблизительно оцените их среднее значение. Потом частоту кадров будете приводить к этому среднему значению. Это важно, т.к. при этом FPS для большинства фрагментов будет меняться незначительно и, следовательно, меньше будет рассинхронизация.

  • Если из всех имеющихся фрагментов всего один или несколько имеют значительно отличающееся значение FPS - обрабатывайте их по отдельности. Т.е. этот один или несколько фрагментов пока не трогайте, возьмите те, что похожи, рассчитайте и приведите их к среднему FPS. Оставшиеся приведите к этому же среднему FPS другим способом, об этом дальше.

  • Если у всех файлов разбег FPS значительный их так же следует приводить к среднему значению, но по-другому.

2.1. Приведение AVI файлов к одному FPS (разбег не значительный).

Обычно, если видео фрагменты захватывались с одного и того же источника, то FPS у них изменяется весьма не значительно. Кроме того, чем фрагменты меньше по продолжительности, тем разбег, еще меньше.

И так мы знаем средний FPS, к которому будем приводить все имеющиеся фрагменты. Открываем в VirtualDub первый AVI файл:

Передвинете ползунок в конец фрагмента или нажмите соответствующую кнопку на панели и посмотрите его продолжительность :

У меня фрагмент имеет продолжительность 0 часов, 08 минут, 40.369 секунд.

Переходим к уже знакомому диалоговому окну:

Выбираем пункт "Change to...". Вписываем среднее известное значение, остальное по умолчанию, нажимаем ОК.

Посмотрите снова на продолжительность вашего фрагмента, теперь она другая:

В силу того, что у меня фрагмент всего 8 минут продолжительностью и FPS изменялся очень не значительно - изменение в его продолжительности составило лишь доли секунды. Это значит, что в конце фрагмента рассинхронизация видео и звука составляет как раз эти доли секунды. Что, в общем-то, совсем не много и даже если очень стараться врятли можно их будет заметить при просмотре. Поэтому я не вижу смысла корректировать синхронизацию, в данном случае, пусть остается, как есть.

Сохраняем изменения FPS. Для этого, предварительно убедитесь, что для видео и аудио потоков, в соответствующих меню, выбран пункт "Direct stream copy". Т.е. потоки будут копироваться без обработки.

Сохраняем.

Таким образом, обрабатываются все фрагменты. Если у всех у них будет такая незначительная рассинхронизация, как в примере, то можно сказать, что вам повезло.

После обработки всех фрагментов, вы можете переходить, непосредственно к соединению AVIшек. Делается это, теперь, в точности так же, как и при идеальном варианте, пункт 1.

Тем же кому, повезло меньше, и рассинхронизация получилась заметной, посвящается дальнейшее описание...

Рассинхронизацию в пределах 0.5 секунд, к концу фрагмента, можно в какой-то степени исправить имеющимися у VirtualDub средствами. Для этого нужно зайти :

Здесь выберете "Preload" и "Interleave.." = 1000ms ... 1500ms. Изменяя значение "Delay audio track by" вы можете немного сдвинуть звук, относительно видео потока. Положительное значение используйте, если звук опережает видео. Отрицательные значения используйте, если наоборот звук отстает от видео.

Вообще, конечно, в нашем случае рассинхронизация имеет нарастающий характер, поэтому ее нельзя исправить простым сдвижением аудио потока, относительно видео потока. Но ее можно в некоторой степени компенсировать или сделать менее заметной.

К примеру, изначально вы имеете, в начале полную синхронизацию, а к концу уход одного потока относительно другого составляет 0.5 секунд. Сделайте так, что бы уже в начале была рассинхронизация 0.25 секунд, таким образом, где-то по середине будет синхронность, а в конце снова уход на 0.25 секунд.

Только не подумайте, что 0.5 секунд - это какое-то ограничение, просто я считаю, что большую рассиннхронизацию, таким сдвижением потока не исправить и не компенсировать, она все равно останется заметной.

Для сохранения изменений в AVI, после изменения параметра "Delay audio track by", так же достаточно выбрать для видео и аудио потоков "Direct stream copy", после чего сохранить.

Тех же, кого не устраивает устранение рассинхронизации за счет сдвижения потока, а так же кому вообще не повезло и имеющаяся рассинхронизация значительна - читайте следующий пункт.

2.2. Приведение AVI файлов к одному FPS (разбег большой).

VirtualDub хорошая программа - это в не сомнения. Однако нет в ней опций, которые могли бы устранить значительную рассинхронизацию видео и звука при большом изменении частоты кадров. Поэтому способ описываемый далее, предполагает обработку звука отдельно от видео...

Открываем в VirtualDub первый AVI файл:

Сохраняем звук открытого AVI в отдельный WAV файл :

Для видео выбираем "Direct stream copy", для звука "No audio" :

Переходим к знакомому диалоговому окну:

Выбираем пункт "Change to...". Вписываем среднее известное значение, остальное по умолчанию, нажимаем ОК.

Перейдите на конец фрагмента, что бы посмотреть его продолжительность, после изменения FPS.

Запишите значение времени. Сохраните AVI.

Таким образом, мы имеет отдельно звук в WAV файле, и имеем AVI файл, с измененным FPS без звука.

Теперь нам понадобиться звуковой редактор, например SonicFoundry Sound Forge или Syntrillium Cool Edit (конечно же, есть и другие). У меня под руками оказалась программа Cool Edit, поэтому я буду рассказывать, и показывать на ее примере.

Запускаем Cool Edit, открываем WAV файл.

Для сжатия/растяжения звука по времени, выбираем в меню:

В диалоговом окне, в поле "Length" необходимо ввести новую длину WAV файла, т.е. то значение, которое мы переписали поле смены FPS в VirtualDub. Значение необходимо вводить в секундах (например, у меня значение 0:07:13.595, в секундах это 7*60+13.595=433.595). Вводим, нажимаем OK :

По окончанию обработки убедитесь, что продолжительность соответствует необходимой. У меня она отличается на 1 тысячную долю секунды, думаю это в пределах допустимого. :)

Сохраняем.

Запускаем VirtualDub, открываем наш AVI файл без звука. Через меню "Audio" подключаем новый звук:

Для сохранения AVI с новым звуком, для видео и аудио потоков выбираем "Direct stream copy" :

Сохраняем.

Так обрабатываем все AVI файлы. Ну а после того как все будет готово, файлы можно соединять так, как это делается при идеальном варианте, пункт 1.

Ну вот вроде и все! :-)

3. Советы и замечания :

  • Приводить частоту кадров имеет смысл только в случае, если исходник не сжат, или сжат MJPEG-ом, Huffyuv-ом. Т.е. кодеком, при сжатии которым, каждый кадр является ключевым. В противном случае, все равно, обрабатываться будут только полные кадры (ключевые) и ничего хорошего не выйдет...

  • Если не исключена возможность пропуска кадров в обрабатываемых фрагментах, то первое, что нужно сделать после открытия исходного авишника ВиртуалДубом (ВД) - проверить его на dropped frames. Жмете shift + "}" для поиска вперёд либо shift + "{" для поиска назад. Удаляете клавишей Delete. Если это не сделать - звук неизбежно разбежится с видеопотоком. Эти манипуляции нужно делать несколько раз, пока ВД не сообщит "no next (previous) dropped frame" (в нижнем левом углу). Эти фреймы ВД просто игнорирует - так что лучше удалить больное место сразу. Только после этого следует переходить к обработке AVI : изменению FPS, сохранению отдельно видео/звука и т.д.

  • Copyright © Олег Антошкив
    Хочу дать совет как избежать процесса перезаписи AVI с целью изменить у него Frame Rate. Для этого достаточно использовать программу : Avifrate1.10 - framerate changer for Avis. Она изменяет Frame Rate в заголовке AVI без перезаписывания всего файла, а это существенно экономит время и не нужно свободного места на диске для промежуточного файла. Я неоднократно использовал эту программу для приведения частоты кадров к одному значению у нескольких AVI и последующей склейки в VirtualDub.

    Со звуком я немного по другому работал: из каждого фрагмента сохранял звук в отдельные файлы, корректировал их длительность, потом склеивал все звуковые фрагменты в один кусок и уже его подключал в VirtualDub в качестве источника звука для "виртуально" соединенных фрагментов видео.